User: Password:
|
|
Subscribe / Log in / New account

SUSE alert SUSE-SU-2014:0510-1 (puppet )

From:  opensuse-security@opensuse.org
To:  opensuse-security-announce@opensuse.org
Subject:  [security-announce] SUSE-SU-2014:0510-1: important: Security update for puppet
Date:  Thu, 10 Apr 2014 19:04:13 +0200 (CEST)
Message-ID:  <20140410170413.A8FC7320A2@maintenance.suse.de>

SUSE Security Update: Security update for puppet ______________________________________________________________________________ Announcement ID: SUSE-SU-2014:0510-1 Rating: important References: #864082 Cross-References: CVE-2013-4761 Affected Products: SUSE Linux Enterprise Server 11 SP3 for VMware SUSE Linux Enterprise Server 11 SP3 SUSE Linux Enterprise Server 11 SP2 LTSS SUSE Linux Enterprise Desktop 11 SP3 ______________________________________________________________________________ An update that fixes one vulnerability is now available. It includes one version update. Description: The deployment framework puppet received an update for a security issue in January. The backport of this security issue was however incomplete and broke existing setups. As the scope of the problem is limited to local scenarios where an attacker likely has access already, and backporting is not trivial, this update reverts the fix for now. We are evaluating the possibility of an update to puppet 2.7 in the future. Security Issue reference: * CVE-2013-4761 <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4761 > Patch Instructions: To install this SUSE Security Update use YaST online_update. Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Server 11 SP3 for VMware: zypper in -t patch slessp3-puppet-9033 - SUSE Linux Enterprise Server 11 SP3: zypper in -t patch slessp3-puppet-9033 - SUSE Linux Enterprise Server 11 SP2 LTSS: zypper in -t patch slessp2-puppet-9034 - SUSE Linux Enterprise Desktop 11 SP3: zypper in -t patch sledsp3-puppet-9033 To bring your system up-to-date, use "zypper patch". Package List: - SUSE Linux Enterprise Server 11 SP3 for VMware (i586 x86_64): puppet-2.6.18-0.14.1 puppet-server-2.6.18-0.14.1 - SUSE Linux Enterprise Server 11 SP3 (i586 ia64 ppc64 s390x x86_64): puppet-2.6.18-0.14.1 puppet-server-2.6.18-0.14.1 - SUSE Linux Enterprise Server 11 SP2 LTSS (i586 s390x x86_64) [New Version: 2.6.18]: puppet-2.6.18-0.14.1 puppet-server-2.6.18-0.14.1 - SUSE Linux Enterprise Desktop 11 SP3 (i586 x86_64): puppet-2.6.18-0.14.1 References: http://support.novell.com/security/cve/CVE-2013-4761.html https://bugzilla.novell.com/864082 http://download.suse.com/patch/finder/?keywords=24c2c59c4... http://download.suse.com/patch/finder/?keywords=a6a498132... -- To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org For additional commands, e-mail: opensuse-security-announce+help@opensuse.org


(Log in to post comments)


Copyright © 2018, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds