User: Password:
|
|
Subscribe / Log in / New account

openSUSE alert openSUSE-SU-2013:1496-1 (xulrunner17)

From:  opensuse-security@opensuse.org
To:  opensuse-updates@opensuse.org
Subject:  openSUSE-SU-2013:1496-1: moderate: update for xulrunner17
Date:  Fri, 27 Sep 2013 16:06:06 +0200 (CEST)
Message-ID:  <20130927140606.818A13238D@maintenance.suse.de>
Archive-link:  Article, Thread

openSUSE Security Update: update for xulrunner17 ______________________________________________________________________________ Announcement ID: openSUSE-SU-2013:1496-1 Rating: moderate References: #840485 Cross-References: CVE-2013-1705 CVE-2013-1718 CVE-2013-1722 CVE-2013-1725 CVE-2013-1730 CVE-2013-1732 CVE-2013-1735 CVE-2013-1736 CVE-2013-1737 Affected Products: openSUSE 12.3 openSUSE 12.2 ______________________________________________________________________________ An update that fixes 9 vulnerabilities is now available. Description: This xulrunner17 version update to 17.0.9esr fixes the following security issues (bnc#840485): * MFSA 2013-65/CVE-2013-1705 (bmo#882865) Buffer underflow when generating CRMF requests * MFSA 2013-76/CVE-2013-1718 Miscellaneous memory safety hazards * MFSA 2013-79/CVE-2013-1722 (bmo#893308) Use-after-free in Animation Manager during stylesheet cloning * MFSA 2013-82/CVE-2013-1725 (bmo#876762) Calling scope for new Javascript objects can lead to memory corruption * MFSA 2013-88/CVE-2013-1730 (bmo#851353) Compartment mismatch re-attaching XBL-backed nodes * MFSA 2013-89/CVE-2013-1732 (bmo#883514) Buffer overflow with multi-column, lists, and floats * MFSA 2013-90/CVE-2013-1735/CVE-2013-1736 (bmo#898871, bmo#906301) Memory corruption involving scrolling * MFSA 2013-91/CVE-2013-1737 (bmo#907727) User-defined properties on DOM proxies get the wrong "this" object Patch Instructions: To install this openSUSE Security Update use YaST online_update. Alternatively you can run the command listed for your product: - openSUSE 12.3: zypper in -t patch openSUSE-2013-717 - openSUSE 12.2: zypper in -t patch openSUSE-2013-717 To bring your system up-to-date, use "zypper patch". Package List: - openSUSE 12.3 (i586 x86_64): mozilla-js-17.0.9-2.1 mozilla-js-debuginfo-17.0.9-2.1 xulrunner-17.0.9-2.1 xulrunner-buildsymbols-17.0.9-2.1 xulrunner-debuginfo-17.0.9-2.1 xulrunner-debugsource-17.0.9-2.1 xulrunner-devel-17.0.9-2.1 xulrunner-devel-debuginfo-17.0.9-2.1 - openSUSE 12.3 (x86_64): mozilla-js-32bit-17.0.9-2.1 mozilla-js-debuginfo-32bit-17.0.9-2.1 xulrunner-32bit-17.0.9-2.1 xulrunner-debuginfo-32bit-17.0.9-2.1 - openSUSE 12.2 (i586 x86_64): mozilla-js-17.0.9-2.1 mozilla-js-debuginfo-17.0.9-2.1 xulrunner-17.0.9-2.1 xulrunner-buildsymbols-17.0.9-2.1 xulrunner-debuginfo-17.0.9-2.1 xulrunner-debugsource-17.0.9-2.1 xulrunner-devel-17.0.9-2.1 xulrunner-devel-debuginfo-17.0.9-2.1 - openSUSE 12.2 (x86_64): mozilla-js-32bit-17.0.9-2.1 mozilla-js-debuginfo-32bit-17.0.9-2.1 xulrunner-32bit-17.0.9-2.1 xulrunner-debuginfo-32bit-17.0.9-2.1 References: http://support.novell.com/security/cve/CVE-2013-1705.html http://support.novell.com/security/cve/CVE-2013-1718.html http://support.novell.com/security/cve/CVE-2013-1722.html http://support.novell.com/security/cve/CVE-2013-1725.html http://support.novell.com/security/cve/CVE-2013-1730.html http://support.novell.com/security/cve/CVE-2013-1732.html http://support.novell.com/security/cve/CVE-2013-1735.html http://support.novell.com/security/cve/CVE-2013-1736.html http://support.novell.com/security/cve/CVE-2013-1737.html https://bugzilla.novell.com/840485


(Log in to post comments)


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds