User: Password:
|
|
Subscribe / Log in / New account

Mageia alert MGASA-2013-0205 (rubygem-passenger)

From:  Mageia Updates <buildsystem-daemon@mageia.org>
To:  updates-announce@ml.mageia.org
Subject:  [updates-announce] MGASA-2013-0205: Updated rubygem-passenger package fixes CVE-2013-2119
Date:  Tue, 9 Jul 2013 20:10:04 +0200
Message-ID:  <20130709181004.61EC840B68@valstar.mageia.org>
Archive-link:  Article, Thread

MGASA-2013-0205 - Updated rubygem-passenger package fixes CVE-2013-2119 Publication date: 09 Jul 2013 URL: http://advisories.mageia.org/MGASA-2013-0205.html Type: security Affected Mageia releases: 3 CVE: CVE-2013-2119 Description: Phusion Passenger’s code did not always create temporary files and directories in a secure manner. Temporary files and directories were sometimes created with a predictable filename. A local attacker can pre-create temporary files, resulting in a denial of service. In addition, this vulnerability allows a local attacker to run arbitrary code as another user, by hijacking temporary files (CVE-2013-2119). The rubygem-passenger package has been upgraded to version 3.0.21, which fixes this issue, as well as many others although at the moment has further issues which will be fixed with another update (mga#10728). References: - http://blog.phusion.nl/2013/05/29/phusion-passenger-3-0-2... - http://blog.phusion.nl/2013/05/29/phusion-passenger-4-0-5... - https://lists.fedoraproject.org/pipermail/package-announc... - https://bugs.mageia.org/show_bug.cgi?id=10728 - https://bugs.mageia.org/show_bug.cgi?id=10497 - http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-2119 SRPMS: - 3/core/rubygem-passenger-3.0.21-2.mga3


(Log in to post comments)


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds