User: Password:
|
|
Subscribe / Log in / New account

Just curious

Just curious

Posted Feb 25, 2013 23:04 UTC (Mon) by sml (subscriber, #75391)
In reply to: Just curious by man_ls
Parent article: Ruby 2.0.0 released

I've worked quite a bit with python 2/3 and ruby 1.8/1.9 and python is certainly far worse with regards to maintaining backwards compatibility.

While there are some incompatible changes in ruby 2, the majority are added features and optimisations, and unlikely to cause major breakage.


(Log in to post comments)

Just curious

Posted Feb 25, 2013 23:20 UTC (Mon) by cortana (subscriber, #24596) [Link]

> python is certainly far worse with regards to maintaining backwards compatibility

The language, the standard library, or third party modules?

Not that it matters if Python sucks for what you're doing--I would just like a little more detail.


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds