User: Password:
Subscribe / Log in / New account

Ubuntu alert USN-1385-1 (apt)

From:  Marc Deslauriers <>
Subject:  [USN-1385-1] APT vulnerability
Date:  Tue, 06 Mar 2012 11:18:56 -0500
Message-ID:  <1331050736.3607.7.camel@mdlinux>
Archive-link:  Article, Thread

========================================================================== Ubuntu Security Notice USN-1385-1 March 06, 2012 apt vulnerability ========================================================================== A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 11.10 - Ubuntu 11.04 Summary: An attacker could trick APT into installing altered packages. Software Description: - apt: Advanced front-end for dpkg Details: Simon Ruderich discovered that APT incorrectly handled repositories that use InRelease files. The default Ubuntu repositories do not use InRelease files, so this issue only affected third-party repositories. If a remote attacker were able to perform a man-in-the-middle attack, this flaw could potentially be used to install altered packages. Update instructions: The problem can be corrected by updating your system to the following package versions: Ubuntu 11.10: apt 0.8.16~exp5ubuntu13.2 Ubuntu 11.04: apt In general, a standard system update will make all the necessary changes. References: CVE-2012-0214 Package Information: -- ubuntu-security-announce mailing list Modify settings or unsubscribe at:

(Log in to post comments)

Copyright © 2018, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds