User: Password:
|
|
Subscribe / Log in / New account

Applications and bundled libraries

Applications and bundled libraries

Posted Mar 18, 2010 11:53 UTC (Thu) by tzafrir (subscriber, #11501)
In reply to: Applications and bundled libraries by Frej
Parent article: Applications and bundled libraries

Because otherwise the developer will need to test N! combinations of interacting versions.


(Log in to post comments)

Applications and bundled libraries

Posted Mar 18, 2010 20:14 UTC (Thu) by Frej (subscriber, #4165) [Link]

Exactly and (M-K)! for K libraries that are bundled ;).
Note that the app developer can choose which the subset K to bundle so the remaining part, M-
K are those such that they are less likely to cause problems.

But the point is that the app developer can fix the error (including version incompatabilities) and
push an update, fixing any problems without the middle-layer of a distro.

I'm not saying this is the best solution for everybody!


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds