The fcntl() system call supports new F_SETOWN_EX and F_GETOWN_EX operations.What astonishingly horrible nondescriptive names. Better names spring to mind instantly: F_SETOWN_THREADSIG / F_GETOWN_THREADSIG perhaps.
Had the author of that patch been using the Win32 API too much recently?
Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds