User: Password:
Subscribe / Log in / New account

The obvious name ...

The obvious name ...

Posted Aug 6, 2009 9:28 UTC (Thu) by eliezert (subscriber, #35757)
In reply to: The obvious name ... by felixfix
Parent article: The realtime preemption endgame

I would call the busywait spinlocks.
This is what they do, and this will also make it obvious they should be used rarely.
I like your cooked / raw proposal, but I think a name the would discourage unnecessary use would be better.

(Log in to post comments)

The obvious name ...

Posted Aug 6, 2009 18:03 UTC (Thu) by cpeterso (guest, #305) [Link]

busywait_spinlock is a great name! It accurately describes its behavior and discourages people from using it (without deep thought).

The obvious name ...

Posted Aug 10, 2009 14:44 UTC (Mon) by kjp (subscriber, #39639) [Link]

I thought atomic_spinlock wasn't too bad, but I like busywait_spinlock.

Of course, I do think it would be better to rename the spinlock itself if it no longer does that....

I guess to facilitate the changeover you could have atomic_lock or busywait_lock (spin is a bit redundant) and mutex, and only very old code would need a typdef for the now non existant 'spinlock' type.

Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds