User: Password:
|
|
Subscribe / Log in / New account

Re: [RFC][PATCH 1/5] Virtualization/containers: startup

From:  Linus Torvalds <torvalds-AT-osdl.org>
To:  Kirill Korotaev <dev-AT-sw.ru>
Subject:  Re: [RFC][PATCH 1/5] Virtualization/containers: startup
Date:  Fri, 3 Feb 2006 09:49:56 -0800 (PST)
Cc:  Kirill Korotaev <dev-AT-openvz.org>, Andrew Morton <akpm-AT-osdl.org>, Linux Kernel Mailing List <linux-kernel-AT-vger.kernel.org>, frankeh-AT-watson.ibm.com, clg-AT-fr.ibm.com, haveblue-AT-us.ibm.com, greg-AT-kroah.com, alan-AT-lxorguk.ukuu.org.uk, serue-AT-us.ibm.com, arjan-AT-infradead.org, Rik van Riel <riel-AT-redhat.com>, Alexey Kuznetsov <kuznet-AT-ms2.inr.ac.ru>, Andrey Savochkin <saw-AT-sawoct.com>, devel-AT-openvz.org, Pavel Emelianov <xemul-AT-sw.ru>
Archive-link:  Article, Thread



On Fri, 3 Feb 2006, Kirill Korotaev wrote:
> 
> Do you have any other ideas/comments on this?
> I will send additional IPC/filesystems virtualization patches a bit later.

I think that a patch like this - particularly just the 1/5 part - makes 
total sense, because regardless of any other details of virtualization, 
every single scheme is going to need this.

So I think at least 1/5 (and quite frankly, 2-3/5 look that way too) are 
things that we can (and probably should) merge quickly, so that people can 
then actually look at the differences in the places that they may actually 
disagree about.

One thing I don't particularly like is some of the naming. To me "vps" 
doesn't sound particularly generic or logical. I realize that it probably 
makes perfect sense to you (and I assume it just means "virtual private 
servers"), but especially if you see patches 1-3 to really be independent 
of any "actual" virtualization code that is totally generic, I'd actually 
prefer a less specialized name.

I realize that what things like this is used for is VPS web hosting etc, 
but that's really naming by current common usage, not by any real "logic".

In other words, I personally would have called them "container" or 
something similar, rather than "vps_info". See? From a logical 
implementation standpoint, the fact that it is right now most commonly 
used for VPS hosting is totally irrelevant to the code, no?

(And hey, maybe your "vps" means something different. In which case my 
argument makes even more sense ;)

		Linus


(Log in to post comments)


Copyright © 2006, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds