User: Password:
|
|
Subscribe / Log in / New account

GCC 4.0.0 not good for KDE

GCC 4.0.0 not good for KDE

Posted May 12, 2005 5:40 UTC (Thu) by dvdeug (subscriber, #10998)
Parent article: First Look at Mandriva Linux 2005 (x86 and x86_64)

GCC 4.0.0 had problems with KDE, so if they compiled their KDE with GCC 4.0, does the code actually work right?


(Log in to post comments)

GCC 4.0.0 not good for KDE

Posted May 12, 2005 9:01 UTC (Thu) by ca9mbu (guest, #11098) [Link]

If they're using a pre-release version of 4.0 they should be alright. The main problem with gcc-4.0.0, from what I understand, is http://gcc.gnu.org/bugzilla/show_bug.cgi?id=21173. This was actually introduced very close to the final release, as described at http://gcc.gnu.org/ml/gcc/2005-04/msg01635.html, so it's likely the Mandriva folks managed to avoid that particular issue.

Regards,

Matt.

GCC 4.0.0 not good for KDE

Posted May 13, 2005 5:27 UTC (Fri) by pynm0001 (guest, #18379) [Link]

The visibility feature has been available as a patch to gcc 3.4 for a
long time now, and lots of distros include the patch by default in their
gcc-3.4. I'm guessing that Mandriva does the same thing.


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds