User: Password:
|
|
Subscribe / Log in / New account

Gentoo alert 201406-26 (django)

From:  Chris Reffett <creffett@gentoo.org>
To:  gentoo-announce@gentoo.org
Subject:  [gentoo-announce] [ GLSA 201406-26 ] Django: Multiple vulnerabilities
Date:  Thu, 26 Jun 2014 18:51:27 -0400
Message-ID:  <53ACA3EF.3050805@gentoo.org>

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Gentoo Linux Security Advisory GLSA 201406-26 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - http://security.gentoo.org/ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Severity: Normal Title: Django: Multiple vulnerabilities Date: June 26, 2014 Bugs: #508514, #510382 ID: 201406-26 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Synopsis ======== Multiple vulnerabilities have been found Django, the worst of which may allow a remote attacker to execute code. Background ========== Django is a Python-based web framework. Affected packages ================= ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-python/django < 1.6.5 >= 1.6.5 *>= 1.5.8 *>= 1.4.13 Description =========== Multiple vulnerabilities have been discovered in Django. Please review the CVE identifiers referenced below for details. Impact ====== A remote attacker could execute code with the privileges of the process, modify SQL queries, or disclose sensitive information. Workaround ========== There is no known workaround at this time. Resolution ========== All Django 1.6 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=dev-python/django-1.6.5" All Django 1.5 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=dev-python/django-1.5.8" All Django 1.4 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=dev-python/django-1.4.13" References ========== [ 1 ] CVE-2014-0472 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0472 [ 2 ] CVE-2014-0473 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0473 [ 3 ] CVE-2014-0474 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0474 [ 4 ] CVE-2014-1418 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1418 Availability ============ This GLSA and any updates to it are available for viewing at the Gentoo Security Website: http://security.gentoo.org/glsa/glsa-201406-26.xml Concerns? ========= Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org. License ======= Copyright 2014 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license. http://creativecommons.org/licenses/by-sa/2.5


(Log in to post comments)


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds