User: Password:
|
|
Subscribe / Log in / New account

Gentoo alert 201405-03 (weechat)

From:  Sean Amoss <ackle@gentoo.org>
To:  gentoo-announce@gentoo.org
Subject:  [gentoo-announce] [ GLSA 201405-03 ] WeeChat: Multiple vulnerabilities
Date:  Sat, 03 May 2014 10:17:44 -0400
Message-ID:  <5364FA88.9070700@gentoo.org>

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Gentoo Linux Security Advisory GLSA 201405-03 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - http://security.gentoo.org/ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Severity: Normal Title: WeeChat: Multiple vulnerabilities Date: May 03, 2014 Bugs: #442600 ID: 201405-03 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Synopsis ======== Two vulnerabilities have been found in WeeChat, the worst of which may allow execution of arbitrary code. Background ========== Wee Enhanced Environment for Chat (WeeChat) is a light and extensible console IRC client. Affected packages ================= ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 net-irc/weechat < 0.3.9.2 >= 0.3.9.2 Description =========== Two vulnerabilities have been discovered in WeeChat: * The hook_process() function does not properly handle shell expansions (CVE-2012-5534). * WeeChat does not properly decode colors which could cause a heap-based buffer overflow (CVE-2012-5854). Impact ====== A remote attacker could entice a user to open a specially crafted script or send messages with specially crafted colors, possibly resulting in execution of arbitrary code with the privileges of the process, or a Denial of Service condition. Workaround ========== There is no known workaround at this time. Resolution ========== All WeeChat users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=net-irc/weechat-0.3.9.2" References ========== [ 1 ] CVE-2012-5534 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-5534 [ 2 ] CVE-2012-5854 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-5854 Availability ============ This GLSA and any updates to it are available for viewing at the Gentoo Security Website: http://security.gentoo.org/glsa/glsa-201405-03.xml Concerns? ========= Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org. License ======= Copyright 2014 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license. http://creativecommons.org/licenses/by-sa/2.5


(Log in to post comments)


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds