User: Password:
|
|
Subscribe / Log in / New account

Fedora alert FEDORA-2014-0621 (graphviz)

From:  updates@fedoraproject.org
To:  package-announce@lists.fedoraproject.org
Subject:  [SECURITY] Fedora 19 Update: graphviz-2.30.1-12.fc19
Date:  Tue, 11 Feb 2014 23:02:24 +0000
Message-ID:  <20140211230224.10FAA2116D@bastion01.phx2.fedoraproject.org>

-------------------------------------------------------------------------------- Fedora Update Notification FEDORA-2014-0621 2014-01-11 07:24:52 -------------------------------------------------------------------------------- Name : graphviz Product : Fedora 19 Version : 2.30.1 Release : 12.fc19 URL : http://www.graphviz.org/ Summary : Graph Visualization Tools Description : A collection of tools for the manipulation and layout of graphs (as in nodes and edges, not as in barcharts). -------------------------------------------------------------------------------- Update Information: This is an update that fixes CVE-2014-1235 and CVE-2014-1236. This is an update that fixes overflow in yyerror. -------------------------------------------------------------------------------- ChangeLog: * Fri Jan 10 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.30.1-12 - Prevent possible buffer overflow in yyerror() Resolves: CVE-2014-1235 - Fix possible buffer overflow problem in chkNum of scanner Resolves: CVE-2014-1236 * Tue Jan 7 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.30.1-11 - Fixed overflow in yyerror Resolves: CVE-2014-0978 * Fri Jul 12 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.30.1-10 - Various man and built-in help fixes * Tue Jun 25 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.30.1-9 - Fixed handling of the libdir/graphviz directory * Tue Jun 11 2013 Remi Collet <rcollet@redhat.com> - 2.30.1-8 - rebuild for new GD 2.1.0 * Wed May 15 2013 Tom Callaway <spot@fedoraproject.org> - 2.30.1-7 - rebuild for lua 5.2 -------------------------------------------------------------------------------- References: [ 1 ] Bug #1050871 - CVE-2014-1235 graphviz: buffer overflow in yyerror() due to improper fix for CVE-2014-0978 https://bugzilla.redhat.com/show_bug.cgi?id=1050871 [ 2 ] Bug #1050872 - CVE-2014-1236 graphviz: buffer overflow vulnerability https://bugzilla.redhat.com/show_bug.cgi?id=1050872 [ 3 ] Bug #1049165 - CVE-2014-0978 graphviz: stack-based buffer overflow in yyerror() https://bugzilla.redhat.com/show_bug.cgi?id=1049165 -------------------------------------------------------------------------------- This update can be installed with the "yum" update program. Use su -c 'yum update graphviz' at the command line. For more information, refer to "Managing Software with yum", available at http://docs.fedoraproject.org/yum/. All packages are signed with the Fedora Project GPG key. More details on the GPG keys used by the Fedora Project can be found at https://fedoraproject.org/keys -------------------------------------------------------------------------------- _______________________________________________ package-announce mailing list package-announce@lists.fedoraproject.org https://admin.fedoraproject.org/mailman/listinfo/package-...


(Log in to post comments)


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds