User: Password:
|
|
Subscribe / Log in / New account

Gentoo alert 201207-08 (gnash)

From:  Sean Amoss <ackle@gentoo.org>
To:  gentoo-announce@gentoo.org
Subject:  [gentoo-announce] [ GLSA 201207-08 ] Gnash: Multiple vulnerabilities
Date:  Mon, 09 Jul 2012 19:49:55 -0400
Message-ID:  <4FFB6E23.1000705@gentoo.org>
Archive-link:  Article, Thread

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Gentoo Linux Security Advisory GLSA 201207-08 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - http://security.gentoo.org/ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Severity: Normal Title: Gnash: Multiple vulnerabilities Date: July 09, 2012 Bugs: #391283, #408209 ID: 201207-08 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Synopsis ======== Multiple vulnerabilities have been found in Gnash which could result in execution of arbitrary code, Denial of Service, or information disclosure. Background ========== Gnash is a GNU flash movie player that supports many SWF features. Affected packages ================= ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 www-plugins/gnash < 0.8.10-r2 >= 0.8.10-r2 Description =========== Multiple vulnerabilities have been found in Gnash: * The "nsPluginInstance::setupCookies()" function in plugin.cpp creates world-readable cookies with predictable file names (CVE-2011-4328). * The "GnashImage::size()" function in GnashImage.h contains an integer overflow error which could cause a heap-based buffer overflow (CVE-2012-1175). Impact ====== A remote attacker could entice a user to open a specially crafted SWF file, possibly resulting in execution of arbitrary code or a Denial of Service condition. Furthermore, a local attacker may be able to obtain sensitive information. Workaround ========== There is no known workaround at this time. Resolution ========== All Gnash users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=www-plugins/gnash-0.8.10-r2" References ========== [ 1 ] CVE-2011-4328 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-4328 [ 2 ] CVE-2012-1175 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1175 Availability ============ This GLSA and any updates to it are available for viewing at the Gentoo Security Website: http://security.gentoo.org/glsa/glsa-201207-08.xml Concerns? ========= Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org. License ======= Copyright 2012 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license. http://creativecommons.org/licenses/by-sa/2.5


(Log in to post comments)


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds