User: Password:
|
|
Subscribe / Log in / New account

openSUSE alert openSUSE-SU-2011:0011-1 (libsmi)

From:  opensuse-security@opensuse.org
To:  opensuse-updates@opensuse.org
Subject:  openSUSE-SU-2011:0011-1 (moderate): libsmi security update
Date:  Mon, 3 Jan 2011 21:08:20 +0100 (CET)
Message-ID:  <20110103200820.63A0EBE67@oldboy.suse.de>
Archive-link:  Article, Thread

openSUSE Security Update: libsmi security update ______________________________________________________________________________ Announcement ID: openSUSE-SU-2011:0011-1 Rating: moderate References: #649867 Cross-References: CVE-2010-2891 Affected Products: openSUSE 11.3 openSUSE 11.2 openSUSE 11.1 ______________________________________________________________________________ An update that fixes one vulnerability is now available. Description: This update fixes a buffer overflow the smiGetNode() function in libsmi. It allowed context-dependent attackers to execute arbitrary code via an Object Identifier. CVE-2010-2891: CVSS v2 Base Score: 7.5 (HIGH) (AV:N/AC:L/Au:N/C:P/I:P/A:P): Buffer Errors (CWE-119) Patch Instructions: To install this openSUSE Security Update use YaST online_update. Alternatively you can run the command listed for your product: - openSUSE 11.3: zypper in -t patch libsmi-3520 - openSUSE 11.2: zypper in -t patch libsmi-3520 - openSUSE 11.1: zypper in -t patch libsmi-3520 To bring your system up-to-date, use "zypper patch". Package List: - openSUSE 11.3 (i586 x86_64): libsmi-0.4.5-131.3.1 libsmi-devel-0.4.5-131.3.1 - openSUSE 11.2 (i586 x86_64): libsmi-0.4.5-127.3.1 libsmi-devel-0.4.5-127.3.1 - openSUSE 11.1 (i586 ppc x86_64): libsmi-0.4.5-1.91.2 libsmi-devel-0.4.5-1.91.2 References: http://support.novell.com/security/cve/CVE-2010-2891.html https://bugzilla.novell.com/649867


(Log in to post comments)


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds