User: Password:
|
|
Subscribe / Log in / New account

Gentoo alert 200801-15 (postgresql)

From:  Raphael Marichez <falco@gentoo.org>
To:  gentoo-announce@gentoo.org
Subject:  [gentoo-announce] [ GLSA 200801-15 ] PostgreSQL: Multiple vulnerabilities
Date:  Tue, 29 Jan 2008 10:41:31 +0100
Message-ID:  <20080129094131.GA2585@falco.falcal.net>
Cc:  bugtraq@securityfocus.com, full-disclosure@lists.grok.org.uk, security-alerts@linuxsecurity.com

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Gentoo Linux Security Advisory GLSA 200801-15 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - http://security.gentoo.org/ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Severity: High Title: PostgreSQL: Multiple vulnerabilities Date: January 29, 2008 Bugs: #204760 ID: 200801-15 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Synopsis ======== PostgreSQL contains multiple vulnerabilities that could result in privilege escalation or a Denial of Service. Background ========== PostgreSQL is an open source object-relational database management system. Affected packages ================= ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-db/postgresql < 8.0.15 >= 8.0.15 *>= 7.4.19 *>= 7.3.21 Description =========== If using the "expression indexes" feature, PostgreSQL executes index functions as the superuser during VACUUM and ANALYZE instead of the table owner, and allows SET ROLE and SET SESSION AUTHORIZATION in the index functions (CVE-2007-6600). Additionally, several errors involving regular expressions were found (CVE-2007-4769, CVE-2007-4772, CVE-2007-6067). Eventually, a privilege escalation vulnerability via unspecified vectors in the DBLink module was reported (CVE-2007-6601). This vulnerability is exploitable when local trust or ident authentication is used, and is due to an incomplete fix of CVE-2007-3278. Impact ====== A remote authenticated attacker could send specially crafted queries containing complex regular expressions to the server that could result in a Denial of Service by a server crash (CVE-2007-4769), an infinite loop (CVE-2007-4772) or a memory exhaustion (CVE-2007-6067). The two other vulnerabilities can be exploited to gain additional privileges. Workaround ========== There is no known workaround for all these issues at this time. Resolution ========== All PostgreSQL users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose "dev-db/postgresql" References ========== [ 1 ] CVE-2007-3278 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3278 [ 2 ] CVE-2007-4769 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4769 [ 3 ] CVE-2007-4772 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4772 [ 4 ] CVE-2007-6067 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6067 [ 5 ] CVE-2007-6600 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6600 [ 6 ] CVE-2007-6601 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6601 Availability ============ This GLSA and any updates to it are available for viewing at the Gentoo Security Website: http://security.gentoo.org/glsa/glsa-200801-15.xml Concerns? ========= Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org. License ======= Copyright 2008 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license. http://creativecommons.org/licenses/by-sa/2.5


(Log in to post comments)


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds