User: Password:
|
|
Subscribe / Log in / New account

Gentoo alert 200409-24 (foomatic)

From:  "Joshua J. Berry" <condordes@gentoo.org>
To:  gentoo-announce@lists.gentoo.org
Subject:  [gentoo-announce] [ GLSA 200409-24 ] Foomatic: Arbitrary command execution in foomatic-rip filter
Date:  Mon, 20 Sep 2004 08:01:06 -0700
Cc:  bugtraq@securityfocus.com, full-disclosure@lists.netsys.com, security-alerts@linuxsecurity.com

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Gentoo Linux Security Advisory GLSA 200409-24 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - http://security.gentoo.org/ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Severity: High Title: Foomatic: Arbitrary command execution in foomatic-rip filter Date: September 20, 2004 Bugs: #64166 ID: 200409-24 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Synopsis ======== The foomatic-rip filter in foomatic-filters contains a vulnerability which may allow arbitrary command execution on the print server. Background ========== Foomatic is a system for connecting printer drivers with spooler systems such as CUPS and LPD. The foomatic-filters package contains wrapper scripts which are designed to be used with Foomatic. Affected packages ================= ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 net-print/foomatic <= 3.0.1 >= 3.0.2 2 net-print/foomatic-filters <= 3.0.1 >= 3.0.2 ------------------------------------------------------------------- 2 affected packages on all of their supported architectures. ------------------------------------------------------------------- Description =========== There is a vulnerability in the foomatic-filters package. This vulnerability is due to insufficient checking of command-line parameters and environment variables in the foomatic-rip filter. Impact ====== This vulnerability may allow both local and remote attackers to execute arbitrary commands on the print server with the permissions of the spooler (oftentimes the "lp" user). Workaround ========== There is no known workaround at this time. Resolution ========== All foomatic users should upgrade to the latest version: # emerge sync # emerge -pv ">=net-print/foomatic-3.0.2" # emerge ">=net-print/foomatic-3.0.2" PLEASE NOTE: You should update foomatic, instead of foomatic-filters. This will help to ensure that all other foomatic components remain functional. References ========== [ 1 ] Foomatic Announcement http://www.linuxprinting.org/pipermail/foomatic-devel/200... [ 2 ] Mandrakesoft Security Advisory http://www.mandrakesoft.com/security/advisories?name=MDKS... [ 3 ] CAN 2004-0801 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0801 Availability ============ This GLSA and any updates to it are available for viewing at the Gentoo Security Website: http://security.gentoo.org/glsa/glsa-200409-24.xml Concerns? ========= Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org. License ======= Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license. http://creativecommons.org/licenses/by-sa/1.0


(Log in to post comments)


Copyright © 2017, Eklektix, Inc.
Comments and public postings are copyrighted by their creators.
Linux is a registered trademark of Linus Torvalds