|| ||Ingo Molnar <mingo-AT-elte.hu> |
|| ||Linus Torvalds <torvalds-AT-linux-foundation.org> |
|| ||Re: [PATCH 00/10] jump label: introduce very_[un]likely + cleanups +
|| ||Fri, 24 Feb 2012 09:04:23 +0100|
|| ||Paul Mackerras <paulus-AT-samba.org>,
"H. Peter Anvin" <hpa-AT-zytor.com>,
Steven Rostedt <rostedt-AT-goodmis.org>,
Jason Baron <jbaron-AT-redhat.com>, a.p.zijlstra-AT-chello.nl,
|| ||Article, Thread
* Linus Torvalds <email@example.com> wrote:
> Seriously, I don't understand why you don't just use the
> obvious name. The data structure is named "static_key". The
> things that change it are named "static_key_inc()" or
> something. So a name like "static_key_true()" is simply
> *better*, isn't it?
Yes, you are right, in hindsight it's indeed obviously and
trivially better :-/
> It's not just about less confusion, it's actually about just
> having consistent naming.
Okay. I sent out the slightly reworked patch that gets rid of
this confusion and makes it all consistent.
to post comments)