An uncommon clock function name
Posted Dec 23, 2011 16:18 UTC (Fri) by nevets
In reply to: An uncommon clock function name
Parent article: A common clock framework
What else could "unprepare" as a verb mean
The process of making yourself unprepared.
To me, it doesn't mean that you have to be prepared in the first place. If you don't do anything to get yourself ready for a presentation, one could say: "I will unprepare myself for the presentation".
Face it, the term sucks. It's silly. startup() and shutdown() are much better terms and more recognizable. As with all technical operations, it is best not to come up with new terms that may lead to confusion. The clearer you make your function names, the clearer you code will be to understand.
to post comments)