2009 Kernel Summit
The eventual merging of sleeping spinlocks from the realtime tree requires
splitting existing locks into two types: those (the majority) which can
sleep in a realtime kernel, and those which must remain "real" spinlocks.
against renaming the vast number of ordinary locks, but did not even
attempt to come up with a name for the "raw" spinlock type.
One possibility was raw_spinlock_t, but that name is already used
by the lockdep code. After numerous other possible names were considered,
the winning suggestion was one by Linus: arch_spinlock_t. This
name carries the connotation of a low-level spinlock which is implemented
by architecture-specific code; in the absence of a better idea, it has
carried the day.
Thomas Gleixner has posted a patch which
makes the naming changes. It's worth noting that even though the new type
is not a raw_spinlock_t, one still calls raw_spin_lock()
to acquire an arch_spinlock_t lock. As of this writing, this
patch has not been merged for 2.6.33, but chances are that it will be.
to post comments)