|| ||"Frank Ch. Eigler" <fche-AT-redhat.com> |
|| ||Andi Kleen <andi-AT-firstfloor.org> |
|| ||Re: [RFC,PATCH 14/14] utrace core |
|| ||Tue, 24 Nov 2009 16:31:05 -0500|
|| ||"Molnar <mingo"@firstfloor.org, Oleg Nesterov <oleg-AT-redhat.com>,
Christoph Hellwig <hch-AT-infradead.org>, utrace-devel-AT-redhat.com,
Alexey Dobriyan <adobriyan-AT-gmail.com>|
|| ||Article, Thread
On Tue, Nov 24, 2009 at 10:26:19PM +0100, Andi Kleen wrote:
> > For example. tracehook_report_syscall_entry() has a lot of callers
> > in arch/, each callsite should be changed to do
> > if ((task_utrace_flags(current) & UTRACE_EVENT(SYSCALL_ENTRY)) &&
> > utrace_report_syscall_entry(regs))
> > ret = -1; // this depends on machine
> > instead of simply calling tracehook_report_syscall_entry().
> That should be in the utrace code?
> I don't have a problem with having common code somewhere,
> just not a whole layer whose only purpose seems to be obfuscation.
One man's obfuscation is another man's abstraction.
Would you be satisfied if "tracehook_" was renamed "utracehook_"?
to post comments)