|| ||Ingo Molnar <mingo-AT-elte.hu>|
|| ||Jeremy Fitzhardinge <jeremy-AT-goop.org>|
|| ||Re: [PATCH 1/2] x86: rename PTE_MASK to PTE_PFN_MASK|
|| ||Tue, 22 Jul 2008 10:36:26 +0200|
|| ||Rusty Russell <rusty-AT-rustcorp.com.au>, linux-kernel-AT-vger.kernel.org|
* Jeremy Fitzhardinge <firstname.lastname@example.org> wrote:
> Rusty, in his peevish way, complained that macros defining constants
> should have a name which somewhat accurately reflects the actual
> purpose of the constant.
> Aside from the fact that PTE_MASK gives no clue as to what's actually
> being masked, and is misleadingly similar to the functionally entirely
> different PMD_MASK, PUD_MASK and PGD_MASK, I don't really see what the
> problem is.
Has Rusty ever heard about the economy of the healthy flow of incoming
regressions? What will we do without obscure names and hard to find
bugs? First he writes a simple and readable hypervisor (ruining a whole
industry based on obscurity!) and now that. It's _so_ unamerican and
unaustralian. I'm worried.
Applied to tip/x86/cleanups anyway. Rusty will find out himself how bad
this whole concept of clean and understandable code is, soon enough!
to post comments)