Posted Jan 12, 2006 22:17 UTC (Thu) by roelofs
Parent article: Looking forward to 2.6.16
The block_device_operations structure has a new method getgeo(); its job is to fill in an hd_geometry structure with information about the drive.
...what a hideous name. "geo" == "Earth," was my first thought, followed immediately by "what the heck does that mean?" and then "maybe 'get geography'??". One extra letter buys you "getgeom()", which is as close to unambiguous as most abbreviations get...but "getgeo()"? Ugh.
Let's go rename all computer/communication/common/comparison/completion-related things to "com" while we're at it. Hrmph.
to post comments)