Why not both?
Posted Dec 15, 2005 18:23 UTC (Thu) by Ross
Parent article: Reworking the semaphore interface
People can have their flag day and also have clearer function names.
Specifically, get rid of up() and down() (those names are too short anyway).
Force all users to either move to sem_up() and sem_down() or sleep_lock() and sleep_unlock(). The advantage (in addition to clarity) is that you will be able to tell old uses of up() and down() from new ones. As code is converted it will be clear which set of functions is intended to be used and code which has not been converted will also be easy to identify.
to post comments)